Debian : Mettre à jour la clé de dépôt sury

Lorsque vous souhaitez mettre à jour votre système vous obtenez le message d’erreur suivant

Err :6 https://packages.sury.org/php buster InRelease
  Les signatures suivantes ne sont pas valables : EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key <[email protected]>

Pour résoudre ce problème, vous devez supprimer la clé expirée

sudo apt-key del B188E2B695BD4743

Ensuite télécharger et ajouter la nouvelle clé

sudo curl -sSL -o /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg

si le paquet curl n’est pas installé dans votre système, faire au préalable :

sudo apt install curl